无法在最新的PHP下安装OELOVE,怎么解决?先谢谢谢谢

bigapple31

2020-12-01 10:00

PHP 5.3.x,If you receive the error "Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4" it means your Zend encoded script will not run on 安装完oelove新版后点击进入管理或首页出现这个:Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /home/laogongl/public_html/upload/source/core/run.php on line 0
美国服务器提供商告诉我它们把服务器刚升级到 PHP 5.3.x,这个版本 Zend Optimizer已经更换为Zend Guard Loader,让我联系你们找一个可以运行在最新版PHP的新脚本或如果脚本允许使用 IonCube,请问我该怎么办?先谢谢谢谢。
附:美国服务器提供商的原文回复:
You should contact the developer for an updated script so it will run on the latest version of PHP or use IonCube instead if your script allows.

Free hosting at GoFreeserve has also recently been upgraded to PHP 5.3.x, in this version Zend Optimizer has been changed to Zend Guard Loader.

2978 次浏览 3 条评论 收藏

说说我的看法

登录后可以发表评论 登录
3个评论
OEdev 2020-12-01 10:00
不支持php5.3,请使用php5.2。
回复
bigapple31 楼主 2020-12-01 10:00
本帖最后由 bigapple31 于 2012-7-17 22:06 编辑

另外,你们最新版的可以支持PHP 5.3.x和Zend Guard Loader吗?最新版的大概什么时侯能推出呢。我用的是OELOVE的这个版本:OELOVE 2.2.1
回复
bigapple31 楼主 2020-12-01 10:00
安装完oelove新版后点击进入管理或首页出现这个:Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /home/laogongl/public_html/upload/source/core/run.php on line 0
美国服务器提供商告诉我它们把服务器刚升级到 PHP 5.3.x,这个版本 Zend Optimizer已经更换为Zend Guard Loader,让我联系你们找一个可以运行在最新版PHP的新脚本或如果脚本允许使用 IonCube,请问我该怎么办?先谢谢谢谢。
附:美国服务器提供商的原文回复:
You should contact the developer for an updated script so it will run on the latest version of PHP or use IonCube instead if your script allows.

Free hosting at GoFreeserve has also recently been upgraded to PHP 5.3.x, in this version Zend Optimizer has been changed to Zend Guard Loader.
回复
作者信息

bigapple31

36
贴子
0
粉丝

免费试用


咨询热线


在线咨询