安装第一步完后出现乱码

2020-12-01 10:00

刚用的这个e-love交友程序,安装第一步完成后首页出现乱码。哪个有经验的人能给帮忙解决下,万分感谢

2866 次浏览 10 条评论 收藏

说说我的看法

登录后可以发表评论 登录
10个评论
jimo30 2020-12-01 10:00
感觉 这个 兼容性 有待考虑提高  我 PHP 538 也是乱码
回复
makingdate 2020-12-01 10:00
wapsky 发表于 2013-4-24 08:37 static/image/common/back.gif
检 查一下php版本及 zend的版本是不是符合我们的环境要求!

安装OELOVE2是环境不符合,必须用PHP5.2.X, 可我用了高级的PHP5.3.8了,我不能因为要装OELOVE2把它卸掉再装低版本的PHP吧
回复
wapsky 官方认证帐号 2020-12-01 10:00
检 查一下php版本及 zend的版本是不是符合我们的环境要求!
回复
makingdate 2020-12-01 10:00
我安装时遇到了和楼主同样的问题。

我在本地windows XP上装OElove V2显示安装成功了,但首页和后台打开是乱码. 刚开始我以为是我没有安装ZendGuardLoader(我用的PHP5.3.8,所以不能安装ZendOptimizer)的原因,但是PHP加载成功ZendLoader.dll后,仍然是出现zend.....\"之类的乱码和以下报错,难道一定要用php 5.2.x和ZendOptimizer 3.3.3的服务器环境?能否请官方给予解释和帮助?

首页显示如下信息:

Zend 2004072203 3 3032 11213x� �2 璠]h � _+.........

Notice: Use of undefined constant BASE_ROOT - assumed \'BASE_ROOT\' in D:\\www\\oelove2\\index.php on line 15

Warning: require_once(BASE_ROOT./source/language/fore.php) [function.require-once]: failed to open stream: No such file or directory in D:\\www\\oelove2\\index.php on line 15

Fatal error: require_once() [function.require]: Failed opening required \'BASE_ROOT./source/language/fore.php\' (include_path=\'.;D:\\amp\\php\\includes\') in D:\\www\\oelove2\\index.php on line 15
--
一个是notice,一个是warning+Fatal error ,请问原因是什么?

第15行代码:
require_once BASE_ROOT.\'./source/language/fore.php\';
回复
yeagou 2020-12-01 10:00
我本地安装没有问题,可是上传到服务器就是乱码
回复
-- 2020-12-01 10:00
我的本地安装了也是出现乱码啊,和楼主的一样{:soso_e118:}
回复
kevinzf521 2020-12-01 10:00
我的和你是一样的情况,好像到目前也还没有有效的解决办法。郁闷ING。一套程序真的很好,本来打算试用一段时间就买商业版的,结果一直不给力啊~~~
回复
zhaoyangengland 2020-12-01 10:00
我试了很多家空间提供商的空间也都是乱码,而试用之前也根本不知道是否支持zend optimizer 3.x,烦死了,现在放弃ing
回复
snh48cn.com 2020-12-01 10:00
我的也是乱码 呢[s:11]
回复
Lee 官方认证帐号 2020-12-01 10:00
PHP环境不支持zend optimizer 3.x,
请安装后再试。
回复
作者信息

1
贴子
0
粉丝

免费试用


咨询热线


在线咨询